Archive

Last modified by Julia Gilmore on 2024-05-24, 10:10

Blog - posts for May 2024

2024-05-10_9-17-45.png

Borealis upgraded to version 6.2 - New Features

Voir l'article de blogue en français

Borealis upgraded to version 6.2 on May 23, 2024. This upgrade brings several new features, including:

  • Geospatial file and metadata improvements [expanded below]
    • Improved Shapefile handling (QPJ and QMD files) 
    • Geographic bounding box metadata validation
    • Corrected field names and tool tips for geographic bounding box metadata
  • Return datasets to author with a note (submit for review workflow) [expanded below]
  • Ability to configure Guestbooks to appear when users request access to restricted files [expanded below]
  • File access requests include date of request in menu
  • Update to all previewers for improved security
  • New previewers [expanded below]
  • Series field now repeatable
  • Search and Facet by License type
  • Support for user browsing by groups of files by folder and category tag [expanded below]
  • Assigning a role with higher permissions than its own is no longer permitted [expanded below]
  • Payara server, Solr indexing, and Java updates
    • Indexing performance improved for large datasets
  • Bug fixes and more!

Full details about the new features and changes can be found in the IQSS GitHub Release pages (English only).  Please note that not all of the features available will be enabled in Borealis.

Please reach out if you have any questions or feedback.

Geospatial files and metadata improvements

What is it?

This upgrade includes several enhancements for geospatial files and metadata, including improved Shapefile handling (QPJ and QMD files), geographic bounding box metadata validation, and corrected field names and tool tips for geographic bounding box metadata.

What is the use-case?

These improvements help to streamline the process of depositing geospatial files, as well as entering accurate geospatial metadata for datasets.

How do I access these features?

When uploading QGIS’s generated shapefiles that contain QPJ and QMD files, the software now properly recognizes and handles them as part of zipped shapefile packages. Previously, QPJ and QMD files were removed from the zip file upon upload.

The Geospatial Metadata Block has several improvements. The Geographic Bounding Box metadata fields are clarified (e.g., “West Longitude” has been updated to “Westernmost (Left) Longitude”). The tooltips (visible when the mouse hovers over the question mark icon) for the Geographic Bounding Box metadata fields are corrected to include decimal degrees, rather than commas.

Screenshot of the Geographic Bounding Box metadata fields with the Southernmost (Bottom) Latitude tooltip visible.

Additionally, the Geographic Bounding Box metadata is now validated upon saving the dataset. If invalid metadata is entered, users will see a validation error message at the top of the dataset metadata page as well as messages for the metadata fields that contain invalid metadata.  

Validation errors when users enter invalid metadata in the Geographic Bounding Box fields.

Validation errors when users enter invalid metadata in the Geographic Bounding Box fields.

Return datasets to author with a note (submit for review workflow)

What is it?

As part of the submit for review workflow, dataset reviewers (i.e., admins, curators) will be prompted via the “return to author” popup window to enter a note outlining the reasons for return. The dataset author will receive an email with details about the return including the note.

What is the use-case?

Previously, dataset authors were often confused about why their dataset was returned to them. Including a note therefore streamlines the submit for review process by providing more information and context to the dataset depositors.

How do I access this feature?

When dataset reviewers (i.e., admins, curators) select the “Publish Dataset” menu and then the option “Return to Author,” they will be prompted with the “Return to Author” popup window to enter a note (maximum 2000 characters). Although this note is mandatory, reviewers could include a meaningful comment to alert the user that more details are forthcoming, such as: “A curation report with comments and suggestions/instructions will follow in another email.”

Note: A copy of the email is not sent to the collection administrators.

Screenshot of the popup menu “Return to Author” with a field to enter a reason for returning the dataset to its author(s).

Screenshot of a sample email sent to the dataset author with the reviewer comment highlighted.

Ability to configure Guestbooks to appear when users request access to restricted files

What is it?

Guestbooks are designed to capture information about users who preview or download dataset files. Originally, guestbooks were only available at the point of file download, but they can now be configured to appear when users request access to restricted files. 

What is the use-case?

Historically, guestbooks assist dataset owners in tracking the users who are downloading their files. The new configuration streamlines the file access request workflow, as dataset owners can review the guestbook responses before deciding whether to grant or deny access to the restricted files.

How do I access this feature?

By default, guestbooks appear at file download. There are two options to change the configuration at the collection level or at the individual dataset level.

First, the feature can be turned on at the collection level. Collection administrators can create a sub-collection where they would change the default from guestbooks at file download to guestbooks at file access request. Under the collection’s Edit menu, select “General Information” and change the “Guestbook Entry Option” to “Guestbook Entry At Access Request.” With this setting, all datasets within the collection will have the guestbooks configured at file access request.

Screenshot of the Guestbook Entry Option menu with the "Guestbook Entry at Request" highlighted

Second, individual datasets can be configured to have the guestbook at file access request. Please contact the Borealis team with the dataset DOI in order for this feature to be turned on per dataset.

How does it work?

Once the setting is configured, a guestbook must be enabled on the dataset.  When users make file-access requests, they will be prompted to fill out the guestbook. To review guestbook responses, collection administrators would go to the collection’s Edit menu and select “Dataset Guestbooks'' to review the Guestbook responses for that dataset. After reviewing the responses, they would go to the dataset’s Edit menu, and select Permissions > File where they can decide whether to grant or reject the access requests. 

Screenshot of the File access request menu with the options to grant or deny access to files.

Note: At this time, this process of reviewing guestbook responses and providing access must be accomplished in two separate menus at the collection level and then the dataset level. Users who do not have access to the collection’s guestbook would need support in accessing the responses (and would need to contact their collection administrator).

New previewers

What is it?

As part of the upgrade, Borealis upgraded to the new version of the standard Dataverse previewers, which brings improvements to all types of file previewers (e.g., image, audio, video, text, PDF). 

What is the use-case?

The new version of the standard Dataverse previewers has important security improvements.  The new previewers dynamically generate signedURLs that grant limited-time access to specific files. They avoid having any form of authorization token appear in the browser history

How do I access this feature?

The security improvements are built into the previewer tools. Stay tuned in a future blog post for more details about how to use newly configured file previewers, including markdown files, zipped shapefiles and GeoTIFFs.

Support for user browsing by groups of files by folder and category tag

What is it?

By default, Dataverse automatically sorts dataset files alphabetically, with limited sorting options (e.g., date, size, file type). The new feature provides additional ways to group the files, by folder (if the dataset is in a hierarchical structure) and by category tag (e.g., data, code, documentation). 

What is the use-case?

The new support for grouping files by folder and category tag provides a way for all users, even file downloaders, to sort the files in different ways to assist in navigating the dataset.

How do I access this feature?

The sorting menu can be found on the dataset page above the file list (beside the sort button). If “Group by Folder” is selected, the files will be presented in order of the folders in the hierarchy. If “Group by Tag” is selected, the file will be sorted into groupings of documentation, data, code, or other custom tags. If neither are selected, it defaults to an alphabetical list. The following screenshot shows the “Group by Tag” is selected, and the files are grouped by tag, with documentation first, followed by data and code.

Screenshot of the dataset file list, with the “Group by Tag” selected and the files ordered from documentation to data to code.

Assigning a role with higher permissions than its own is no longer permitted

What is it?

This upgrade brings a fix to a permissions issue where users previously could assign roles to themselves or others that were higher than their own. This type of privilege escalation is no longer permitted.

What is the use-case?

Collection administrators can have confidence that users will not be able to give themselves or others higher permissions than they are allowed.

How do I access this feature?

If a user (e.g., Contributor Plus) attempts to assign a role higher than their own (e.g., Curator or Admin), they will receive an error message “The role was not able to be assigned.”Screenshot of the error message “The role was not able to be assigned” 

2024-05-10_9-17-21.png

Borealis mis à jour vers la version 6.2 - Nouvelles fonctionnalités

View English blog post

Borealis a été mis à jour vers la version 6.2 le 23 mai 2024. La mise à niveau comporte de nombreuses nouvelles fonctionnalités, y compris : 

  • Amélioration des fichiers et des métadonnées géospatiales [détails ci-bas]
    • Amélioration de la gestion des fichiers Shapefile (fichiers QPJ et QMD)
    • Validation des métadonnées de la de zone de délimitation géographique
    • Correction des noms de champs et des infobulles pour les métadonnées de la zone de délimitation géographique
  • Renvoi des jeux de données à l'autrice ou l’auteur avec une note (processus de révision) [détails ci-bas]
  • Possibilité de configurer les Registres des visites afin qu’ils s'affichent lors de la demande d’accès à des fichiers restreints [détails ci-bas]
  • Les demandes d'accès aux fichiers incluent la date de la demande dans le menu
  • Sécurité amélioré pour tous les outils de prévisualisation
  • Nouveaux outils de prévisualisation [détails ci-bas]
  • Le champ "série" est désormais répétable
  • Recherche et facettes par type de licence
  • Prise en charge de la navigation dans les groupes de fichiers par dossier et étiquette de catégorie [détails ci-bas]
  • Il n'est plus possible d'attribuer à un rôle des autorisations plus élevées que les siennes [détails ci-bas]
  • Mises à jour du serveur Payara, de l'indexation Solr et de Java
    • Amélioration des performances d'indexation pour les grands ensembles de données
  • Corrections de bogues, et plus encore!

Toute l’information sur ces nouvelles fonctionnalités et ces changements se trouve dans les pages des notes de version GitHub d’IQSS (en anglais uniquement). Prenez note que les fonctionnalités décrites ne seront pas toutes activées dans Borealis.

N’hésitez pas à communiquer avec nous pour toute question ou commentaire.

Amélioration des fichiers et des métadonnées géospatiales

Qu’est-ce que c’est?

Cette mise à jour comprend plusieurs améliorations pour les fichiers géospatiaux et les métadonnées, notamment une meilleure gestion des fichiers Shapefile (fichiers QPJ et QMD), la validation des métadonnées de la zone de délimitation géographique, ainsi que la correction des noms des champs et des infobulles pour les métadonnées de la zone de délimitation géographique.

Quel est le cas d’utilisation?

Ces améliorations permettent de simplifier le processus de dépôt des fichiers géospatiaux, ainsi que la saisie de métadonnées géospatiales précises pour les jeux de données.

Comment accéder à cette fonctionnalité?

Lors du téléchargement de fichiers Shapefile en provenance de QGIS et contenant des fichiers QPJ et QMD, le logiciel les reconnaît comme faisant partie d'un fichier Shapefile dans une archive ZIP. Auparavant, les fichiers QPJ et QMD étaient supprimés du fichier ZIP lors du téléchargement.

Le bloc de métadonnées géospatiales a fait l'objet de plusieurs améliorations. Les champs de métadonnées de la zone de délimitation géographique ont été clarifiés (par exemple, "Longitude Ouest" a été mis à jour pour "Longitude ouest (gauche) ") et les infobulles (visibles lorsque la souris survole l'icône du point d'interrogation) pour les champs de métadonnées de la zone géographique ont été corrigées pour inclure les degrés décimaux (point plutôt que virgule).

Capture d’écran de la Zone de délimitation géographique montrant l’affichage d’une infobulle

De plus, les métadonnées de la zone de délimitation géographique sont désormais validées lors de l’enregistrement du jeu de données. Si des métadonnées non valides sont saisies, un message d'erreur de validation s'affichera en haut de la page de métadonnées du jeu de données, ainsi que des messages spécifiques près des champs de métadonnées qui contiennent des métadonnées non valides.  

Capture d'écran du message "erreur de validation".

Capture d’écran de la Zone de délimitation géographique montrant ce qui s’affiche lors d’erreurs de validation

Renvoi des jeux de données à l'autrice ou l’auteur avec une note (processus de révision)

Qu’est-ce que c’est?

Dans le cadre du processus de soumission pour révision, les personnes ayant les fonctions d’administration ou de curation seront invitées, via la fenêtre contextuelle "Retourner à l’auteur", à saisir une raison pour laquelle l’ensemble de données est renvoyé. L'auteur ou l’autrice de l'ensemble de données recevra un courriel contenant les détails du retour, y compris la raison inscrite dans la fenêtre contextuelle.

Quel est le cas d’utilisation?

Précédemment, les auteurs et autrices d'ensembles de données ne savaient pas toujours pourquoi leur ensemble de données leur était renvoyé. L'inclusion d'une raison permet donc de clarifier le processus de révision en fournissant davantage d'information.

Comment accéder à cette fonctionnalité?

Lorsque les personnes ayant les fonctions d’administration ou de curation sélectionnent le menu "Publier l'ensemble de données" puis l'option "Retourner à l'auteur", la fenêtre contextuelle "Retourner à l'auteur" les invite à saisir une raison pour le retour (2 000 caractères maximum). Bien que ce champ soit obligatoire, il est possible d’inclure un commentaire significatif pour avertir que des précisions supplémentaires sont à venir, comme par exemple : "Un rapport de curation avec des commentaires et des suggestions/instructions suivra dans un autre courriel."

Capture d'écran de la fenêtre contextuelle "Retourner à l'auteur" avec le champ permettant de saisir la raison du retour.

Notes : Le courriel contenant une raison pour le renvoi n’est pas envoyé aux administratrices et administrateurs de collection. De plus, les courriels envoyés dans le cadre du processus de révision contiennent quelques erreurs de traduction. Nous travaillons à les corriger le plus rapidement possible.

Possibilité de configurer les Registres de visites afin qu’ils s'affichent lors de la demande d’accès à des fichiers restreints

Qu’est-ce que c’est?

Les registres des visites sont conçus pour recueillir des informations sur les personnes qui prévisualisent ou téléchargent des fichiers. À l'origine, les registres des visites n'étaient disponibles qu'au moment du téléchargement des fichiers, mais ils peuvent désormais être configurés pour apparaître lors de la demande d’accès à des fichiers en accès restreint. 

Quel est le cas d’utilisation?

Historiquement, les registres des visites aident les propriétaires d'ensembles de données à suivre qui téléchargent leurs fichiers. La nouvelle configuration améliore le processus de demande d'accès aux fichiers, car les propriétaires de jeux de données peuvent consulter les réponses du registre de visites avant de décider d'accorder ou de refuser l'accès aux fichiers en accès restreint.

Comment accéder à cette fonctionnalité?

Par défaut, les registres des visites apparaissent lors du téléchargement des fichiers. Il existe deux options pour modifier la configuration au niveau de la collection ou au niveau de l'ensemble de données.

Tout d'abord, la fonctionnalité peut être activée au niveau de la collection. Les administrateurs et administratrices de collections peuvent créer une sous-collection dans laquelle la valeur par défaut des registres des visites sera modifiée pour être activée lors de la demande d'accès aux fichiers. Dans le menu Modifier de la collection, sélectionnez "Renseignements généraux" et modifiez l'"Option d'entrée du registre de visites" en "Entrée du registre de visites à la demande d'accès". Avec ce paramètre, tous les ensembles de données de la collection auront les registres de visite configurés pour apparaître lors de la demande d'accès au fichier.

Capture d'écran du menu de l'option d'entrée du registre des visites avec l'option "Entrée du registre de visites à la demande d'accès" sélectionné en surbrillance.

Il est aussi possible d’activer un registre des visites à la demande d’accès pour un ensemble de données spécifique. Veuillez contacter l'équipe Borealis avec le DOI de l'ensemble de données pour demander l’activation de cette fonction pour un ensemble de données.

Comment l’utliser?

Une fois le paramètre configuré, un registre des visites doit être activé sur l'ensemble de données.  Lors de la demande d'accès aux fichiers, le visiteur ou la visiteuse doit remplir le registre des visites. Pour consulter les réponses, l’administrateur ou l’administratrice d’une collection doit aller dans le menu  “Modifier” de la collection et sélectionner “Registres de visites de l'ensemble de données” pour consulter les réponses au registres de visites de cet ensemble de données.  Après avoir examiné les réponses, il faut se rendre dans le menu Édition de l'ensemble de données et sélectionner Permissions > Fichier, pour décider d'accorder ou de rejeter les demandes d'accès. 

Capture d'écran du menu des demandes d'accès aux fichiers avec les options permettant d'accorder ou de refuser l'accès aux fichiers.

Note: Pour l'instant, ce processus d'examen des réponses au registres de visites et d'octroi de l'accès doit être réalisé dans deux menus distincts au niveau de la collection, puis au niveau de l'ensemble de données. Les personnes qui n'ont pas accès au registre des visites de la collection auront besoin d'aide pour accéder aux réponses et devront communiquer avec la personne responsable de leur collection institutionnelle.

Nouveaux outils de prévisualisation

Qu’est-ce que c’est?

Dans le cadre de la mise à jour, Borealis a adopté la nouvelle version des outils de prévisualisation standard de Dataverse, qui apporte des améliorations à tous les types de prévisualisation de fichiers (par exemple, image, audio, vidéo, texte, PDF).

Quel est le cas d’utilisation?

La nouvelle version des outils de prévisualisation de Dataverse présente d'importantes améliorations en matière de sécurité.  Les nouveaux outils de prévisualisation génèrent dynamiquement des URL signées qui accordent un accès limité dans le temps à des fichiers spécifiques. Ils évitent qu'un jeton d'autorisation apparaisse dans l'historique du navigateur.

Comment accéder à cette fonctionnalité?

Les améliorations en matière de sécurité sont intégrées dans les outils de prévisualisation. Restez à l'affût pour plus de détails dans un prochain billet de blogue sur l'utilisation des outils de prévisualisation de fichiers nouvellement configurés, y compris les fichiers Markdown, les fichiers Shapefile zippés et les GeoTIFFs.

Prise en charge de la navigation dans les groupes de fichiers par dossier et libellé

Qu’est-ce que c’est?

Par défaut, Dataverse trie automatiquement les fichiers de l'ensemble de données par ordre alphabétique, avec des options de tri limitées (par exemple, la date, la taille, le type de fichier). La nouvelle fonctionnalité permet de regrouper les fichiers par dossier (si l'ensemble de données se trouve dans une structure hiérarchique) et par libellés (par exemple, données, code, documentation). 

Quel est le cas d’utilisation?

La nouvelle fonction de regroupement des fichiers par dossier et par libellé permet à tout le monde, même les personnes qui téléchargent des fichiers, de trier les fichiers de différentes manières pour faciliter la navigation dans l'ensemble des données.

Comment accéder à cette fonctionnalité?

Le menu de tri se trouve sur la page de l'ensemble de données, au-dessus de la liste des fichiers (à côté du bouton Trier). Si l'option "Grouper par dossier" est sélectionnée, les fichiers seront présentés dans l'ordre des dossiers de la hiérarchie. Si l'option "Grouper par libellé" est sélectionnée, le fichier sera trié par groupes de documentation, de données, de code ou d'autres libellés personnalisés. Si aucune de ces options n'est sélectionnée, une liste alphabétique est proposée par défaut. La capture d'écran suivante montre que l'option "Grouper par libellé" est sélectionnée et que les fichiers sont regroupés par libellé, avec la documentation en premier, suivie des données et du code.

Capture d'écran de la liste des fichiers de l'ensemble de données, avec l'option "Grouper pas libellé" sélectionnée et les fichiers classés par libellés.

Il n'est plus possible d'attribuer à un rôle des autorisations plus élevées que les siennes

Qu’est-ce que c’est?

Cette mise à jour apporte un correctif à un problème de permissions où les utilisateurs pouvaient auparavant s'attribuer ou attribuer à d'autres des rôles plus élevés que les leurs. Ce type d'escalade des privilèges n'est plus autorisé.

Quel est le cas d’utilisation?

Les administrateurs et administratrices de collections peuvent avoir la garantie que les utilisateurs et utilisatrices ne pourront pas s'attribuer ou attribuer à d'autres des autorisations supérieures à celles qui leur sont accordées.

Comment accéder à cette fonctionnalité?

Si, par exemple, une personne ayant le rôle Collaboration Plus, tente d'attribuer un rôle supérieur au sien (comme Curation ou Administration), elle recevra un message d'erreur "Le rôle n'a pu être assigné".

Capture d’écran du message d’erreur “Le rôle n’a pu être assigné”